Update your Opayo Plugin before the 14th March to prevent interruptions to your Opayo payment service. 

Approx 2 Minute Read

If you are using our JSWeb Opayo (formerly known as Sagepay) Integration Module with your Zencart website, this article is of great importance to you and your e-commerce website. You will probably have been receiving messages from Opayo about the SCA Deadline on 14 March 2022. SCA (Strong Customer Authentication) implementation involves upgrading all credit card systems from 3DS to 3DS2. E-commerce websites must “add an extra layer of identity confirmation before the user pays so that transactions meet the SCA rules” (source: UK Gov).

This affects both you  and your business because payment methods for websites must meet these standards and submit the required information to allow the transaction to complete. E-commerce websites must upgrade or they will see an increase in failed transactions. The final implementation of 3DS2 has been delayed for a variety of reasons, including Covid-19, but the end is now nigh for the old 3DS.

In order to implement 3DS2 you need our most recent edition (v22.3.8) of the plugin which we have just completed testing (our apologies – some late changes by Opayo). This plugin is only guaranteed to function correctly on Zencart 1.5.7 or later – it has not been, and will not be, tested on out-dated versions. 

JSWeb Opayo For Zencart

If you want to install the upgrade yourself, you can download the latest copy now from your JSWeb account at https://my.jsweb.uk/clientarea.php – Please note, you must have a current Support & Upgrades service in place to be able to download the new version. If you need to renew, please go to https://my.jsweb.uk/cart.php?gid=addons
If you prefer us to install the upgrade for you, please send a message to our team and we’ll get it done. There is a fee of £55+vat for this service. 

Client Area

 

As always, we recommend that you are using the latest version of both Zencart and our JSWeb Opayo Module in order to have the most seamless, error-free experience. If you are worried that your current Zencart version may not be compatible and that this may in some way affect your ability to make sales though your e-commerce don’t panic! The JSWeb team are here to help. Simply open a support ticket, let us know your current Zencart version and we can get back to you within 48 hours with a rough quote to upgrade your site. 

If you’re using another platform for your Opayo payments such as WooCommerce we suggest that you login to your admin/dashboard and make sure that your WordPress version, WooCommerce version and Opayo plugin are all up-to-date. If you have any further questions, feel free to get in touch!

Get In Touch